Here, we will show you the possible way to fix the issue of the subscription that is suspended by Plesk.
Symptom
- Every day, the subscription is suspended automatically.
- The website is not accessible with "503 Service Temporarily Unavailable" or "The service is unavailable" error.
Cause
It can be suspended according to the settings, like expiration date or resource limits.
Resolution
To fix the issue, you need to check the resource limit of the account. If it is exceeded, then you need to assign more resources to it. Below are the steps on how to increase the resource limit of the account from the Plesk Panel.
Increase the resource limits
Step 1: Log in to Plesk
Step 2: Find out what limits have been exceeded by a subscription/reseller.
For a reseller: Go to Plesk -> Resellers -> Username -> View More Statistics -> Resources.

For a subscription: Go to Plesk -> Subscriptions -> domain name -> Account -> Resources.

Step 3: Increase such limits.
After that, you need to review the expiration date of the subscription. If it has expired, you need to increase it. You can also set it to unlimited.
Below are the steps on how to increase the expiration date of the subscription from the Plesk Panel.
Increase the expiration date
Step 1: Log in to Plesk
Step 2: Activate subscription.
Plesk -> Subscription -> website name -> Activate

Step 3: Correct the settings for the subscription.
Under the service plan of subscription under Plesk -> Service Plans -> Service Plan -> Resources

Also, this parameter can be configured at on subscription level.
Go to Plesk -> Subscriptions -> domain name -> Customize -> Resources Tab.

Note: demovpstest.com is our testing domain name and website. Here, we have used it for testing purposes.