Fix - PHPMyAdmin Error You should upgrade to MySQL 5.5.0 or later Print

  • 1

Problem statement


Recently we upgraded phpMyAdmin version from 4.0.10.12 to 4.5.3.1 in our customer's Windows VPS. Right after the upgrade, we noticed that phpMyAdmin login screen is no longer appeared and threw an error shown in following screen capture.

phpMyAdmin Error

Error message

 

PHPMyAdmin -  Error

You should upgrade to MySQL 5.5.0 or later.


Solution


The customer was running phpMyAdmin version 4.0.10.12 which is compatible with PHP 5.2 and MySQL 5 only. To run the current version of phpMyAdmin 4.5.3.1, the server must have PHP 5.5 to 7.0 and MySQL 5.5. We performed following steps to fix this issue.

  1. Navigate to installation path of phpMyAdmin upto file common.inc.php.

    For Windows server - C:\inetpub\wwwroot\phpMyAdmin\libraries\common.inc.php
    For Linux server - /usr/share/phpMyAdmin/libraries/common.inc.php
  2. Edit common.inc.php file with an editor and comment out following code block.

    if (PMA_MYSQL_INT_VERSION < $cfg['MysqlMinVersion']['internal']) {
    PMA_fatalError(
    __('You should upgrade to %s %s or later.'),
    array('MySQL', $cfg['MysqlMinVersion']['human'])
    );
    }
  3. Save the file and access phpMyAdmin website.


Was this answer helpful?

« Back
Sign up for a newsletter

chat