Fix :: Operation must use an updateable query." for ASP pages

Problem Statement

Operation must use an updateable query." for ASP pages


There might be several reasons for this error. One of the most common reason is inappropriate permissions.

Error message

Getting the error Microsoft JET Database Engine error '80004005'
Operation must use an updateable query.
/myfolder/test-page.asp, line 315



  1. Login to your server with administrator user.
  2. Locate wwwroot folder of your website ( usually located at c:\inetpub\ or c:\Hosting Spaces\\ )
  3. Click on Properties >> Security.
  4. Click on Edit and select the IIS_IUSRS.
  5. Check the checkbox against necessary permission (Read, Write and Modify) from the permissions list and click on OK.

  • 0 Users Found This Useful

Was this answer helpful?

Related Articles

FIX :: .inc include files not loading in ASP .NET website

Sometimes, your website doesn't load .inc files like of your ASP .net website.The .inc...

How to Run Multiple PHP Versions in Windows VPS?

There are times when your PHP websites rely on functions/features that are available only in some...

How to create a certificate signing request [CSR] from IIS 7.5 in your VPS?

Follow the below mentioned steps to create Certificate signing request from IIS 7.5 in your VPS:...

How to resolve configuration error of 'targetFramework'?

Steps to Change Application Pool of a Website from IIS: Login to your VPS. Open Start >...

How to Backup/Restore IIS7 Configuration?

IIS 7 automatically makes history snapshots of ApplicationHost.config each time a change is...