How to Fix 'SSL certificate problem: unable to get local issuer certificate' Error Print

  • 0

When running the old version of WordPress, you may face an issue (as shown below) while upgrading WordPress to the newer version or installing the WordPress plugins.

ssl-error

So, if you encounter this error in the Windows server, one option to fix this issue is through the following steps -  

  1. Download cert.pem from the URL http://curl.haxx.se/docs/caextract.html

  2. Copy the cert.pem file to your PHP installation folder.
    Generally, the php.ini path should be C:\Program Files (x86)\PHP\vx.x\ 
    So you will need to copy the cert.pem file to the same folder.

  3. Edit your php.ini file and add the following line under the curl section. 
    Do not forget to replace the PHP path.

curl.cainfo = "C:\Program Files (x86)\PHP\vx.x\cacert.pem"

SSL-certificate-problem-php-ini

4. Save the php.ini file and restart the IIS. 

5. Run the following command to restart the IIS:

> iisreset /restart

SSL-certificate-problem-iis-reset

Following these steps should fix the issue, and you will be able to install a plugin or upgrade WordPress with ease.

 


Was this answer helpful?

« Back

chat