CVE-2019-0708: Remote Desktop Services Remote Code Execution Vulnerability On Windows 2003, Windows 2008 and Windows 2008 R2

Dear Valued Client,Microsoft has recently indicated a potential vulnerability  (CVE-2019-0708) residing in its “Remote Desktop Service” of Windows 2003, Windows 2008 and Windows 2008 R2 operating systems. A patch is available thru a Windows Update and we are in the process of updating the same.As this is a manual process, it will take us ... Read More »

14th May 2019